wenyanJavaScript编码|爱游戏体育平台
作者:    发布于:2021-05-03    文字:【】【】【
本文摘要:爱游戏体育,爱游戏体育平台,近日有开发者开源系统了一门新的编程语言,吸引住了很多开发者的眼光,几天得到了5kstar。该语言表达名叫“文言文wenyan-lang”,它是一门选用古文键入的编程语言,该语言表达不包括英文字符,仅包括繁体版标识符,并保存繁体引号「」。

近日有开发者开源系统了一门新的编程语言,吸引住了很多开发者的眼光,几天得到了5k star。该语言表达名叫“文言文wenyan-lang”,它是一门选用古文键入的编程语言,该语言表达不包括英文字符,仅包括繁体版标识符,并保存繁体引号「」。

编程语言

先看一下Helloworld要怎么写:吾有一數。曰三。名之曰「甲」。為是「甲」遍。

吾有一言。曰「「問天地好在。」」。書之。

等等。这一段编码等效于下列JavaScript编码:varn=3;forvari=0;i2{return"ofcourse";}若三并不大於五者。乃得「「想當然耳」」。

既非。乃得「「怪哉」」也。

if3<=5{return"ofcourse"}else{return"noway"}為是千遍百遍。⋯⋯等等。forvari=0;i<100;i {...}恆為是。⋯⋯等等。

whiletrue{...}凡「天地」中之「人」。⋯⋯等等。forvarhumanofworld{...}乃止。

break;计算wenyanJavaScript加一以二。1 2加一於二。2 1加一以二。

乘其以三。1 2*3除十以三。

所餘幾何。10%3減七百五十六以四百三十三。名之曰「甲」。vara=756-433;夫「甲」「乙」中有陽乎。

a||b夫「甲」「乙」中無陰乎。a&&b器皿二维数组从1逐渐数据库索引。

wenyanJavaScript吾有一列。名之曰「甲」。充「甲」以四。

以二。vara=[];a.push4,2;銜「甲」以「乙」。以「丙」a.concatb.concatc;夫「甲」之一。a[0]夫「甲」之其餘。

a.slice1;夫「玫瑰花」之「「名」」。rose["name"]夫「寶劍」之長。sword.length;涵数wenyanJavaScript吾有一術。

名之曰「吸星大法」。是術曰。⋯⋯是謂「吸星大法」之術也。

天地

functionf{...}吾有一術。名之曰「六脈神劍」。欲行是術。

当以得六數。曰「甲」。曰「乙」。曰「丙」。

曰「丁」。曰「戊」。曰「己」乃行是術曰。

⋯⋯是謂「六脈神劍」之術也。functionfa,b,c,d,e,f{...}吾有一術。名之曰「翻番」。

欲行是術。当以得一數。曰「甲」。乃行是術曰。

乘「甲」以二。名之曰「乙」。

乃得「乙」。是謂「翻番」之術也。

functiondoublea{varb=a*2;returnb;}可是创作者表明前后文不相干的英语的语法叙述仍在搭建中。文言文语言表达选用自然语言理解解决共享资源了古典风格汉语语法,将语言表达编译程序为JavaScript或Python,而且图灵完备。另外它不但出示了一个配套设施线上IDE,还出示了很多优化算法与算法设计实例,包含灭火吹、汉诺塔问题与斐波那契数列表明等。

--------------------------------华为云服务邀约您关心最強AI技术博客号,包含前沿的技术性动态性、技术性文章内容、实例实战演练等,除此之外关心有机会赚取精致巨奖HDC.Cloud门票费、AI课程内容、AI书本。点一下https://url.cn/8klEr02,登陆华为云账号,关心。

抽奖方式请见社区论坛文章内容。


本文关键词:爱游戏体育平台,开发者,不包括,於二,加一,有一

本文来源:爱游戏体育-www.midatlanticff.com

上一篇:张国全:小米10至尊纪念版掩藏功能_爱游戏体育
下一篇:c-爱游戏体育
脚注信息

地址: 贵州省黔南布依族苗族自治州三都水族自治县代天大楼61号    电话: 080-745042960    传真: 095-756923148
爱游戏体育,爱游戏体育平台    E-mail: admin@midatlanticff.com    备案号:贵ICP备76294884号-4